Usage Notes

 

Office 365 Compatibility Requirements

Please note that there are specific OS requirement for the download of Office 365, available for currently enrolled students, Staff and Faculty through the software.usf.edu site.

It is important to know when you purchase a computer or laptop and plan to use this software, that it is not compatible with the Chrome OS, or with versions of LINUX or UNIX. These are great machines for inexpensive computing needs, however Microsoft Office client applications require MS Windows, or Mac OSX.

Online use of these application is also available through Office 365, and works with all browsers, much in the same manner as Google Drive.

Last edited on September 12, 2018